1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rgss3 player has stopped working error

Discussion in 'Solved' started by YesMan, Apr 16, 2018.

  1. YesMan

    YesMan Member

    35
    14
    Jun 17, 2017
    Anytime I attempt to play a game with with this player, I get this error. Anyone know a fix?
     
  2. TCMS

    TCMS OtterBean Staff Member Moderator Donor

    4,563
    1,673
    Aug 5, 2016
    Any log or anything? Pc specs? OS? Laptop?
     
  3. a meme

    a meme Active Member

    284
    234
    Sep 26, 2017
    Ctrl + C on your error message and ctrl + V the message here. Also what TCMS said. It could be some c++ redistributable that's missing, but normally RPGmaker should work with a clean install of anything ranging from windows XP to 10.
     
  4. YesMan

    YesMan Member

    35
    14
    Jun 17, 2017
    [Window Title]
    RGSS3 Player

    [Main Instruction]
    RGSS3 Player has stopped working

    [Content]
    A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

    [Close program]

    ----------------------------------------------------------------------------

    That's the error message.

    __________________________________________________
    Grade A1 Acer Aspire Z5761 23"
    • Processor: Intel Core i3-2100 (3.1GHz/3MB cache)
    • Operating System: Windows 7 Home Premium 64Bit Edition
    • Memory: 4GB DDR3 RAM
    • Hard Drive: 1.5TB
    • Graphics: Integrated (Intel HD Graphics)
    • ---------------------------------------------------
    These are the specs. Bear in mind its an old computer as well.
     
  5. Nightcrawler

    Nightcrawler Carpe Diem Donor Jr. Uploader

    367
    180
    May 23, 2017
    have you tried uninstalling then reinstalling the VX Ace RTP?

    Please Log in / Register to view this link

     
  6. YesMan

    YesMan Member

    35
    14
    Jun 17, 2017
    Yeah, still got the same problem.
     
  7. Nightcrawler

    Nightcrawler Carpe Diem Donor Jr. Uploader

    367
    180
    May 23, 2017
    This is a mistake i have made myself in the past.Have you checked you are running the correct RTP for the game you wish to play as their are several itterations of RPG Maker. just throwing ideas into the mix
     
  8. YesMan

    YesMan Member

    35
    14
    Jun 17, 2017
    Just tried downloading them all and attempted to boot up several RPG games, same error popped up for all of them.
     
  9. AlbericEtzel

    AlbericEtzel Member

    29
    4
    Apr 29, 2017
    Well, That's same as when i try LOQO Origin. It's RGSS Player has stopped working.
     
  10. Dragoman

    Dragoman Member

    41
    13
    Jun 8, 2017
    I think i know how to solve this problem:-
    1.First open Start Menu
    2.Select Control Panel
    3.Go to System and Security
    4.Then click on System
    5.On the left hand side,Click on Advanced System Settings
    6.A new window will pop up called System Properties
    7.Click on Advanced Tab,under the Performance section click on Settings
    8.Another window will pop up called Performance Options
    9.Click on Data Execution Prevention
    10.Under Data Execution Prevention,click on Turn on DEP for all programs and services those i select (Basically second option)
    11.Click on add and browse your rpg maker executable file for that game( it is usually game.exe) and select it
    12.Finally click on Apply
    That's it,let me know if it worked.
     
  11. Mikadesu!

    Mikadesu! Member

    15
    1
    Mar 8, 2018
    usually whre did that rpg maker executable file at??i cant find it though...
    i found the other game.exe files but it show notice "You can not set DEP attribute on 64 bit executable

    help pls
     
  12. Dragoman

    Dragoman Member

    41
    13
    Jun 8, 2017
    when i said "rpg maker executable file" i meant the executable file of the game you are trying to play that you have to put under dep not the executable file of the rpg maker program(like mv,vx,2000 etc).And about that DEP attribute error,what os you are using and do you get the com surrogate error? Tell me about it.
     
  13. FreakyFarm86

    FreakyFarm86 Member

    35
    9
    May 23, 2018
    try this form me works perfectly:
    - Close game
    - Open Start menu, choose Run (on Windows 10, right-click Start and choose Run)
    - Type regedit
    - In the menu bar at the top, go to Edit and then Find
    - Type Enterbrain and press OK
    - Wait for search to finish
    - Right-click on Enterbrain folder and delete
     
Loading...